Scheduled Platform Maintenance
Scheduled for June 23, 2025 at 7:00 PM – 10:00 PM
Affects
Platform
Under maintenance from 7:00 PM to 10:00 PM
Email Sending
Under maintenance from 7:00 PM to 10:00 PM
Email Test Sending
Under maintenance from 7:00 PM to 10:00 PM
Email Links
Under maintenance from 7:00 PM to 10:00 PM
SMS Sending
Under maintenance from 7:00 PM to 10:00 PM
Data Upload
Under maintenance from 7:00 PM to 10:00 PM
Completed
June 23, 2025 at 10:00 PMCompleted
June 23, 2025 at 10:00 PMMaintenance has completed successfully
In progress
June 23, 2025 at 7:00 PMIn progress
June 23, 2025 at 7:00 PMMaintenance is now in progress
Planned
June 23, 2025 at 7:00 PMPlanned
June 23, 2025 at 7:00 PMWe will be performing a scheduled update to the Force24 platform to support continued performance and reliability.
During this time:
The platform may be temporarily inaccessible.
All outbound communications (emails, SMS, WhatsApp) will be paused.
Any messages due to be sent during this period will be safely queued and processed automatically once the update is complete.
We expect the maintenance to be completed smoothly, with no action required on your part.
If you have any questions, please contact our Product Expert team.
Thank you for your patience and continued support.