Force24 - Site Down – Incident details

All systems operational

Site Down

Resolved
Major outage
Started 3 months agoLasted about 14 hours

Affected

Platform

Major outage from 6:51 AM to 6:52 AM, Operational from 6:52 AM to 9:16 AM, Major outage from 9:16 AM to 8:21 PM, Degraded performance from 8:21 PM to 9:18 PM

Email Sending

Major outage from 6:51 AM to 6:52 AM, Operational from 6:52 AM to 9:16 AM, Major outage from 9:16 AM to 8:21 PM, Degraded performance from 8:21 PM to 9:18 PM

Email Test Sending

Major outage from 6:51 AM to 6:52 AM, Operational from 6:52 AM to 9:16 AM, Major outage from 9:16 AM to 8:21 PM, Degraded performance from 8:21 PM to 9:18 PM

Email Links

Major outage from 6:51 AM to 6:52 AM, Operational from 6:52 AM to 9:16 AM, Major outage from 9:16 AM to 8:21 PM, Degraded performance from 8:21 PM to 9:18 PM

SMS Sending

Major outage from 6:51 AM to 6:52 AM, Operational from 6:52 AM to 9:16 AM, Major outage from 9:16 AM to 8:21 PM, Degraded performance from 8:21 PM to 9:18 PM

Data Upload

Major outage from 6:51 AM to 6:52 AM, Operational from 6:52 AM to 9:16 AM, Major outage from 9:16 AM to 8:21 PM, Degraded performance from 8:21 PM to 9:18 PM

Updates
  • Resolved
    Resolved

    Force24 is now online and fully functional, all emails and SMS are queued and currently sending.

    All journeys and automated lists are also back online.

    Note, any emails that you had set send windows for during the day will not be sent if they are no longer within the window.

    The product experts will be available for additional training sessions tomorrow and Friday to support you with any follow up questions you may have.

    Over the coming hours and day we will be conducting an internal review and will share an incident report in the coming days.

  • Monitoring
    Monitoring

    The engineers have completed their work and Force24 services are starting to resume. The team will continue to monitor and there will be a further update to follow.

    Once a complete review has been completed an incident report will be shared in the coming days.

  • Update
    Update

    The engineers have nearly completed the physical work on site and our development team are on standby to complete the handover to Force24.

    There will be a further update at 6pm to outline services restoration for customers.

  • Update
    Update

    Good Afternoon,

    Having received a further update from the engineering teams and our hosting partner, the parts have now been delivered and the latest estimated time of service restoration is 5pm.

    Another update will follow shortly.

  • Update
    Update

    The engineering teams are continuing their work onsite, progress has been made by the hosting provider, but at this stage Force24 remains down.

    There will be a further update at 2pm on progress and a confirmation on when services will be restored.

  • Update
    Update

    The issue relates to a larger data centre outage, the engineers are onsite and working on getting the system back up and running. Our latest estimate is all systems will be back up and running by 1pm.

    Further updates to come.

  • Identified
    Identified
    We have identified the issue and are continuing to work to bring all functionality back online
  • Investigating
    Investigating
    We are currently investigating this incident.